Problem mit dem KDE 4.8.3 Update

In diversen Foren ist im Zusammenhang mit dem Update unter openSUSE auf KDE 4.8.3 ein Fehler bekannt geworden, bei dem nach dem Update  kein grafischer Login mehr möglich sein soll bzw selbiger nur im “Abgesicherten Modus” funktioniert. Bei meinem eigenen Update mit einem meiner Rechner unter openSUSE 12.1 bei dem ich auch die Release-Repos nutze konnte ich diesen Fehler ebenfalls feststellen. Beim Loginfenster kam ich nach Eingabe des Passwortes immer wieder in eine Schleife und landete wieder beim Loginfenster. Bei Updates bei denen ich die Factory Repos genutzt habe ist dieser Fehler nicht aufgetreten.

 

Wie sich herausstellt liegt das Login-Problem wohl an einem falschen Eintrag für den “Anmeldemanager” .

 

Um das zu korrigieren geht ihr folgendermaßen vor:

 

Wenn Ihr ebenso nach dem Update bei dem Login Fenster hängen bleibst könnt ihr entweder die KDE Session im „abgesicherten Modus“ starten oder ihr wählt einen anderen Fenstermanager ( falls vorhanden) zum starten aus. Bei mir stand unter anderem auch noch der Fenstermanager „icewm“ zur Verfügung. Dieser bringt zwar keinen wirklich komfortabler Desktop zum Arbeiten mit, ist aber ausreichend um diese Fehlerbehebung durchzuführen. Ich habe mein openSUSE 12.1 also in diesem Fall ab dem Login Fenster mit dem Icewn gestartet. Auch von da kommt man gut an Yast ran und nur das brauchen wir jetzt. 😉

Yast starten > links „System“ auswählen und dann rechts „Editor für ect/sysconfig“ anklicken

 

Hier klicken wir uns wie auf dem Screenshot zu sehen durch „Desktop“ > „Window Manager“ > „Default_WM“

 

Auf der rechten Seite wählen wir dann aus dem Dropdown-Menü statt „KDE4“ den Eintrag „KDE“ aus und speichern die Auswahl mit einem Klick auf „OK“.

 

Danach kann der Editor und Yast geschlossen werden und nach einem Neustart des Systems sollte das normale Login in die KDE Umgebung wieder funktionieren. Ich nehme an, dass dieser Fehler auch bald durch die KDE Entwickler ausgeräumt sein sollte. Nur bis dahin kann man sich mit dem oben beschriebenen behelfen.

GD Star Rating
loading...
Problem mit dem KDE 4.8.3 Update, 10.0 out of 10 based on 9 ratings
Bookmark the permalink.

6 Responses to Problem mit dem KDE 4.8.3 Update

  1. derAndreas says:

    Habe Deinen Artikel gerade gelesen –
    bei mir steht -kde4- und es funktioniert.
    Bin dann wohl die Ausnahme von der Regel 😉

    GD Star Rating
    loading...
  2. Thomas says:

    Und du hast welches Repo für KDE 4.8.3 ? Release oder Factory?
    Interessant, scheint also nicht in jedem Fall so zu sein.

    GD Star Rating
    loading...
  3. Linuxsusefan says:

    oder openSUSE 11.4 wo es das beschriebene Problem auch nicht auftritt, so eine Info eines Lesers meines Blog Artikels … 🙂

    Grüße aus dem Länd’le

    GD Star Rating
    loading...
  4. iamthegodofhellfire says:

    Hi, den Fehler hatte ich auch. Installiert wurde das Update aus dem „Release“-Repo. Ich habe einfach beim Start nochmal den Fenstermanager auf „KDE“ gestellt und schon war es gut. 🙂

    GD Star Rating
    loading...
  5. mojo says:

    Hallo, auch ich habe Deinen Artikel gelesen, Deine Anweisungen befolgt und: Mein geupdatetes KDE ist tatsächlich wieder hochgefahren! Vielen Dank für Deinen Tipp!:)

    GD Star Rating
    loading...
  6. Herbert says:

    Hallo,
    jetzt wird es ganz merkwürdig:
    Ich habe auf meinem Lapi einen User bei dem das Logg in mit „KDE4“ geht, bei einem zweiten user geht es nicht.

    Nur zur Info

    Gruß Herbert

    GD Star Rating
    loading...

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.