aktuelles Problem mit NVIDIA Treiber Update

Die letzten Tage habe ich mich mit einem unschönen Problem rumgeärgert. Beim Start meines Rechners eines Morgens funktionierte der KDE Plasma Desktop nicht mehr und dafür kam eine Absturzmeldung vom KRunner. Die kam aber nicht nur ein mal, sondern müllte mir akribisch im Sekundentakt meinen Bildschirm zu.

Also, wem ähnliche Probleme zur Zeit das Leben schwer machen, hier die Lösung  (..die vorläufige.. 😉 )

Die Informationen zu der Lösung dieses Problems habe ich bei Diskussionen im openSUSE Forum und bei lisufasblog gefunden.

Das Problem besteht in manchen Fällen im Zusammenhang mit folgenden Voraussetzungen:

  1. NVIDIA Grafikkarte
  2. KDE SC 4.5.2
  3. Neuer NVIDIA Treiber 260.19.12

Scheinbar besteht eine Unverträglichkeit in einigen Fällen. Bisher gibt es noch keine offizielle Meldung dazu. Aber die Mehrheit der User bestätigen diese Möglichkeit.

Lösung:

Bis das Problem mit diesem neuen Treiber gelöst ist, sollte man wieder zu der vorherigen Treiberversion wechseln. Wie immer gibt es bei openSUSE dafür mehrere Möglichkeiten.

Wenn man an Yast aus dem KDE Desktop noch rankommt ist es kein Problem. ( bei mir war es so doll, dass ich den Umweg über einen anderen Desktop [Gnome] bei der Anmeldung genommen habe)

Dann startet ihr „Software“ -> „Software Repositories

Deaktiviert das aktuelle NVIDIA Repository!

und bindet ein NVIDIA Archiv als Repository ein.

http://anorien.warwick.ac.uk/mirrors/opensuse/nvidia/download.nvidia.com/opensuse/11.3/

Das Ersatzweise eingebundene NVIDIA Treiber Archiv

Dann braucht man über Yast nur noch ein Downgrade auf  Treiber 256.53 durchführen und der KDE Desktop funktioniert wieder.

Downgrade des NVIDIA Treibers mittels Yast

Etwas fortgeschrittene Linuxer werden diese Aktion schneller in der Konsole mit zypper erledigen.

GD Star Rating
loading...
aktuelles Problem mit NVIDIA Treiber Update, 7.2 out of 10 based on 11 ratings
Tagged , , , . Bookmark the permalink.

8 Responses to aktuelles Problem mit NVIDIA Treiber Update

  1. Tuxgo says:

    Ich habe KDE 4.4.4, aber Amarok 2.3.2 lief in letzter Zeit nicht mehr. Ich hatte schon den aktualisierten Nvidia-Treiber im Verdacht (wusste zwar wie man eine Downgrade macht, kannte aber nur das von Yast einstellbare Nvidia-Repository). Nach dem Downgrade auf 256.53 läuft Amarok wieder. Werde mit dem Update auf 260.19.12 (und auf KDE 4.5.2) lieber noch etwas warten.

    Schönen Gruß

    GD Star Rating
    loading...
  2. Tuxgo says:

    Habe heute eine Software-Aktualisierung per Yast gemacht und unvorsichtigerweise wieder ein Update auf 260.19.12 durchgeführt (Amarok geht wieder nicht mehr). Das im Text genannte Repository bietet die alte Treiberversion 256.53 nicht mehr an. Gibt’s noch ein Repository, mit dem ich das Downgrade nochmal machen kann?
    Schönen Dank im Voraus!

    GD Star Rating
    loading...
  3. admin says:

    Naja, Du könntest den 260-ger Treiber wieder deinstallieren und dir dann den 253-ger Treiber direkt von der Nvidia-Seite http://www.nvidia.de/Download/Find.aspx?lang=de holen. Das ist dann aber die manuelle Installation. Dateiname: NVIDIA-Linux-x86-256.53.run .
    In diesem Artikel (http://www.opensuse-lernen.de/?p=70) habe ich die manuelle Installation am Beispiel von früheren Versionen und zu Zeiten wo Sax2 noch dabei war erklärt. Heute ist es eventuell ähnlich, mit einigen Abweichungen.
    Gruß Thomas

    GD Star Rating
    loading...
  4. mattmarr says:

    Gibt es noch weiter repositorys wo ich den 256.53 finden kann um ihn per Yast zu installieren?

    Bei mir ist auch der 260 drauf und macht probleme mit z.b. Amarok.

    Gruß Matthias

    GD Star Rating
    loading...
  5. admin says:

    Bisher habe ich noch keine anderen gefunden. Zumindest bei mir blieb nur die manuelle Installation des 256 Nvidia Treibers. Als Hilfestellung bietet sich diese Beschreibung an.
    Gruß Thomas

    GD Star Rating
    loading...
  6. robbie21 says:

    Es scheint seit heute so, dass das NVIDIA Plasma Problem seit heute mit dem neusten Beta-Treiber 270.29 behoben ist.

    Ich habe ihn mir installiert und stelle auf den ersten Blick keine Fehler mehr fest.

    Den Treiber gibt es hier:

    ftp://download.nvidia.com/XFree86/Linux-x86/270.29/

    GD Star Rating
    loading...
  7. Lisufa says:

    Hi,

    nix da, zumindest bei mir bzw meinen beiden Notebooks nicht! Immer noch dasselbe Schauspiel: → Treiber Download → alten entfernen → neu starten (R.3) → neuen Treiber installiert (o.P.) → init 5 → neu einloggen → schon hagelt es Crash-Meldungen (kein nutzen des Desktops mehr möglich) wie gehabt!! Bei beiden Geräten dasselbe Ergebnis → ich könnt Ko….!

    Ich denke mir mal das es ggf sogar auch bei Nutzern zweierlei Auswirkungen des Problem‘ s gibt.
    Die einen:
    – bei denen der Desktop (wie bei mir) gar nicht mehr nutzbar ist weil hier ‚zig Crash-Meldungen von Plasma es unmöglich machen damit zu arbeiten.

    – die anderen bei denen der Plasma nicht so Crash‘ t wie bei o.g. Gruppe dafür aber manche Anwendungen (Amarok, KTorrent etc → siehe Foren-Infos betroffener User) sich nicht verwenden lassen und so dafür sorgen das der Desktop nicht vernünftig nutzbar ist.

    Abschließend für mich, das Treiber Paket von dem hier die Rede ist macht zumindest bei meiner Hardware nichts anderes als die schon vorher erschienen Treiber. Einzig der 256.53 ‚ziger Treiber ist bei mir nutzbar!!

    Dennoch einen schönen Tag ….. 😉

    GD Star Rating
    loading...
  8. Lisufa says:

    Hi,

    ich kann nun auch vermelden das bei meiner vorhandenen Hardware & meinem System ich die Sache (nicht unbedingt nach meinen Vorstellungen, da Beta Kram) geregelt hab. So bin ich vorgegangen:

    – den heute (Info dort: http://www.nvnews.net/vbulletin/showthread.php?p=2399427) zum testen freigegeben 270.30 für 32 Bit Architektur (ftp://download.nvidia.com/XFree86/Linux-x86/270.30/) herunter geladen.

    – Dann auf den im Repo: Kernel-Stabil (OSS11.3) aktuellen (2.6.37.2) angebotenem Kernel aktualisiert. (Grund: ich will vorerst nicht auf die 11.4 Upgraden aber dennoch nicht auf den 37′ ziger Kernel verzichten)

    – System neu Starten (init 3)
    – danach den 270.30 Beta Treiber nach üblichen Vorgehensweisen (How-To‘ s) installiert.

    – dann System neu gestartet, diesmal ohne irgendwelche Plasma Crash‘ s und dergleichen. Soweit ich das zumindest bei mir überblicken kann, ist das Problem nun erledigt …..!!

    Aber, wie mehrmals schon erwähnt ist das ein Beta Treiber der als solches nicht unbedingt auf einem Produktiv System verwendet werden sollte da dieser noch Fehler haben kann die Schäden am System verursachen könnten.

    Wer auf Nummer sicher gehen will, sollte besser noch abwarten und den 256.53′ ziger Treiber weiterhin benutzen bis es eine offizielle stabile Variante der kommenden Finalen Version zur Verwendung gibt!

    Grüße aus dem Länd‘ le …. 😉

    GD Star Rating
    loading...

Kommentar verfassen